aboutsummaryrefslogtreecommitdiff
path: root/crn/packages
diff options
context:
space:
mode:
Diffstat (limited to 'crn/packages')
-rw-r--r--crn/packages/cpp.scm25
-rw-r--r--crn/packages/games.scm39
-rw-r--r--crn/packages/go-xyz.scm148
-rw-r--r--crn/packages/lua-xyz.scm60
-rw-r--r--crn/packages/patches/cpplint-pytest-version.patch13
-rw-r--r--crn/packages/patches/rofi-extra-whitespace.patch13
-rw-r--r--crn/packages/patches/sway-contrib-python.patch10
-rw-r--r--crn/packages/wm.scm39
-rw-r--r--crn/packages/xdisorg.scm29
9 files changed, 0 insertions, 376 deletions
diff --git a/crn/packages/cpp.scm b/crn/packages/cpp.scm
deleted file mode 100644
index 4120342..0000000
--- a/crn/packages/cpp.scm
+++ /dev/null
@@ -1,25 +0,0 @@
-(define-module (crn packages cpp)
- :use-module (crn packages)
- :use-module (gnu packages)
- :use-module (gnu packages cpp)
- :use-module (guix packages)
- :use-module (guix git-download))
-
-(define-public cpplint-up
- (package (inherit cpplint)
- (name "cpplint-up")
- (version "1.5.5")
- (source
- (origin
- (method git-fetch)
- ;; Fetch from github instead of pypi, since the test cases are not in
- ;; the pypi archive.
- (uri (git-reference
- (url "https://github.com/cpplint/cpplint")
- (commit version)))
- (sha256
- (base32 "13l86aq0h1jga949k79k9x3hw2xqchjc162sclg2f99vz98zcz15"))
- (file-name (git-file-name name version))
- (patches (crn/search-patches "cpplint-pytest-version.patch"))))))
-
-cpplint-up
diff --git a/crn/packages/games.scm b/crn/packages/games.scm
deleted file mode 100644
index c41106a..0000000
--- a/crn/packages/games.scm
+++ /dev/null
@@ -1,39 +0,0 @@
-(define-module (crn packages games)
- #:use-module (gnu packages)
- #:use-module (gnu packages sdl)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix build-system gnu)
- #:use-module (guix download)
- #:use-module (guix gexp)
- #:use-module (guix packages)
- #:use-module (guix utils)
- #:use-module (srfi srfi-26))
-
-(define-public black-box
- (package
- (name "black-box")
- (version "1.4.8")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.linux-games.com/" name "/" name "-" version ".tar.gz"))
- (sha256
- (base32 "1gbkkf05qy6zz0s2v1yyjrhrnw0nxl1ldzm4fdlwi1z4jqda7xlw"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-SDL
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "CPATH"
- (string-append
- (assoc-ref inputs "sdl-union") "/include/SDL:"
- (or (getenv "CPATH") ""))))))))
- (inputs (list (sdl-union (list sdl sdl-mixer sdl-image))))
- (synopsis "Guess where the crystals are!")
- (description "There's a black box.
-You can shoot in and watch, where the shot leaves the box. In the box,
-crystals are reflecting the shots. You have to guess where the crystals
-are hidden, by watching your shots.")
- (home-page "https://www.linux-games.com/black-box/")
- (license license:gpl2+)))
diff --git a/crn/packages/go-xyz.scm b/crn/packages/go-xyz.scm
deleted file mode 100644
index f40aee8..0000000
--- a/crn/packages/go-xyz.scm
+++ /dev/null
@@ -1,148 +0,0 @@
-(define-module (crn packages go-xyz)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix gexp)
- #:use-module (guix git-download)
- #:use-module (guix utils)
- #:use-module (gnu packages)
- #:use-module (gnu packages golang)
- #:use-module (gnu packages golang-check))
-
-(define-public go-1.21
- (package
- (inherit go-1.20)
- (name "go")
- (version "1.21.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/golang/go")
- (commit (string-append "go" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xp1mqjbbs53bjg00d4a37af5p1by28xnflj2xi5kchcpmlqn5nz"))))
- (arguments
- (substitute-keyword-arguments (package-arguments go-1.20)
- ;; Source patching phases are broken up into discrete steps to
- ;; allow future versions to discard individual phases without
- ;; having to discard all source patching.
- ((#:phases phases)
- #~(modify-phases #$phases
- (delete 'skip-TestGoPathShlibGccgo-tests)
- (delete 'patch-source)
- (add-after 'unpack 'patch-os-tests
- (lambda _
- (substitute* "src/os/os_test.go"
- (("/usr/bin") (getcwd))
- (("/bin/sh") (which "sh")))))
-
- (add-after 'unpack 'apply-patches
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Having the patch in the 'patches' field of <origin>
- ;; breaks the 'TestServeContent' test due to the fact
- ;; that timestamps are reset. Thus, apply it from here.
- (invoke "patch" "-p1" "--force" "-i"
- (assoc-ref inputs "go-fix-script-tests.patch"))))
-
- (add-after 'unpack 'patch-src/net
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((net-base (assoc-ref inputs "net-base")))
- (substitute* "src/net/lookup_unix.go"
- (("/etc/protocols")
- (string-append net-base "/etc/protocols")))
- (substitute* "src/net/port_unix.go"
- (("/etc/services")
- (string-append net-base "/etc/services"))))))
-
- (add-after 'unpack 'patch-zoneinfo
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Add the path to this specific version of tzdata's
- ;; zoneinfo file to the top of the list to search. We
- ;; don't want to replace any sources because it will
- ;; affect how binaries compiled with this Go toolchain
- ;; behave on non-guix platforms.
- (substitute* "src/time/zoneinfo_unix.go"
- (("var platformZoneSources.+" all)
- (format #f "~a~%\"~a/share/zoneinfo\",~%"
- all
- (assoc-ref inputs "tzdata"))))))
-
- (add-after 'unpack 'patch-cmd/go/testdata/script
- (lambda _
- (substitute* "src/cmd/go/testdata/script/cgo_path_space.txt"
- (("/bin/sh") (which "sh")))))
-
- (add-after 'enable-external-linking 'enable-external-linking-1.21
- (lambda _
- ;; Invoke GCC to link any archives created with GCC
- ;; (that is, any packages built using 'cgo'), because Go
- ;; doesn't know how to handle the runpaths but GCC does.
- ;; Use substitute* rather than. a patch since these
- ;; files are liable to change often
- ;;
- ;; XXX: Replace with GO_EXTLINK_ENABLED=1 or similar
- ;; when <https://github.com/golang/go/issues/31544>
- ;; and/or <https://github.com/golang/go/issues/43525>
- ;; are resolved.
- (substitute* "src/cmd/link/internal/ld/config.go"
- (("\\(iscgo && \\(.+\\)") "iscgo"))
- (substitute* "src/internal/testenv/testenv.go"
- (("!CanInternalLink.+") "true {\n"))
- (substitute* "src/syscall/exec_linux_test.go"
- (("testenv.MustHaveExecPath\\(t, \"whoami\"\\)")
- "t.Skipf(\"no passwd file present\")"))))
-
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Notably, we do not install archives (180M), which Go
- ;; will happily recompile quickly (and cache) if needed,
- ;; almost surely faster than they could be substituted.
- ;;
- ;; The main motivation for pre-compiled archives is to
- ;; use libc-linked `net' or `os' packages without a C
- ;; compiler, but on Guix a C compiler is necessary to
- ;; properly link the final binaries anyway. Many build
- ;; flags also invalidate these pre-compiled archives, so
- ;; in practice Go often recompiles them anyway.
- ;;
- ;; Upstream is also planning to no longer install these
- ;; archives: <https://github.com/golang/go/issues/47257>
- ;;
- ;; When necessary, a custom pre-compiled library package
- ;; can be created with `#:import-path "std"' and used
- ;; with `-pkgdir'.
- ;;
- ;; When moving files into place, any files that come
- ;; from GOROOT should remain in GOROOT to continue
- ;; functioning. If they need to be referenced from some
- ;; other directory, they need to be symlinked from
- ;; GOROOT. For more information, please see
- ;; https://github.com/golang/go/issues/61921
- (let* ((out (assoc-ref outputs "out"))
- (tests (assoc-ref outputs "tests")))
- (for-each
- (lambda (file)
- (copy-recursively file (string-append out "/lib/go/" file)))
- '("bin" "go.env" "lib" "VERSION" "pkg/include" "pkg/tool"))
-
- (symlink "lib/go/bin" (string-append out "/bin"))
-
- (for-each
- (match-lambda
- ((file dest output)
- ;; Copy to output/dest and symlink from
- ;; output/lib/go/file.
- (let ((file* (string-append output "/lib/go/" file))
- (dest* (string-append output "/" dest)))
- (copy-recursively file dest*)
- (mkdir-p (dirname file*))
- (symlink (string-append "../../" dest) file*))))
- `(("src" "share/go/src" ,out)
- ("misc" "share/go/misc" ,out)
- ("doc" "share/doc/go/doc" ,out)
- ("api" "share/go/api" ,tests)
- ("test" "share/go/test" ,tests))))))))))))
-
-(define-public go-std-1.21 (make-go-std go-1.21))
diff --git a/crn/packages/lua-xyz.scm b/crn/packages/lua-xyz.scm
deleted file mode 100644
index 286ecd3..0000000
--- a/crn/packages/lua-xyz.scm
+++ /dev/null
@@ -1,60 +0,0 @@
-(define-module (crn packages lua-xyz))
-(use-modules (guix git)
- (guix git-download)
- (guix gexp)
- (guix download)
- (guix packages)
- (guix licenses)
- (guix build-system cmake)
- (guix utils)
- (gnu packages)
- (gnu packages bash)
- (gnu packages glib)
- (gnu packages linux)
- (gnu packages lua)
- (gnu packages pkg-config)
- (gnu packages python-xyz)
- (gnu packages valgrind)
- (gnu packages xorg)
- (gnu packages web))
-
-(define-public luastatus
- (package
- (name "luastatus")
- (version "0.6.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/shdown/luastatus")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1xyh220par0f8l8ylh6jx0qzskafwy1hi0v1dw22qs0g6nkbj4y2"))))
- (build-system cmake-build-system)
- (native-inputs (list lua
- pkg-config
- python-docutils
- valgrind))
- (inputs (list alsa-lib
- bash
- xcb-util
- yajl
- glib
- libnl
- eudev
- libx11
- libxcb
- xcb-util-wm))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "../source/tests/misc.sh" ".")
- (invoke "../source/tests/torture.sh" ".")))))))
- (home-page "https://github.com/shdown/luastatus")
- (synopsis "Universal status bar content generator")
- (description "Luastatus is a universal status bar content generator.
-It allows you to configure the way the data from event sources is
-processed and shown, with Lua.")
- (license gpl3)))
diff --git a/crn/packages/patches/cpplint-pytest-version.patch b/crn/packages/patches/cpplint-pytest-version.patch
deleted file mode 100644
index a388d4a..0000000
--- a/crn/packages/patches/cpplint-pytest-version.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 0297e74..357adcb 100755
---- a/setup.py
-+++ b/setup.py
-@@ -75,7 +75,7 @@ setup(name='cpplint',
- long_description=open('README.rst').read(),
- license='BSD-3-Clause',
- setup_requires=[
-- "pytest-runner==5.2"
-+ "pytest-runner"
- ],
- tests_require=test_required,
- # extras_require allow pip install .[dev]
diff --git a/crn/packages/patches/rofi-extra-whitespace.patch b/crn/packages/patches/rofi-extra-whitespace.patch
deleted file mode 100644
index 1d065f7..0000000
--- a/crn/packages/patches/rofi-extra-whitespace.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/source/modes/dmenu.c b/source/modes/dmenu.c
-index 27b6097d..85dda8e5 100644
---- a/source/modes/dmenu.c
-+++ b/source/modes/dmenu.c
-@@ -391,7 +391,7 @@ static gchar *dmenu_format_output_string(const DmenuModePrivateData *pd,
- unsigned int index =
- (unsigned int)g_ascii_strtoull(pd->columns[i], NULL, 10);
- if (index <= ns && index > 0) {
-- if (i == 0) {
-+ if (index == 1) {
- g_string_append(str_retv, splitted[index - 1]);
- } else {
- g_string_append_c(str_retv, '\t');
diff --git a/crn/packages/patches/sway-contrib-python.patch b/crn/packages/patches/sway-contrib-python.patch
deleted file mode 100644
index ff4f344..0000000
--- a/crn/packages/patches/sway-contrib-python.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/firefox-focus-monitor.py b/firefox-focus-monitor.py
-old mode 100644
-new mode 100755
-index d2a2d42..659b893
---- a/firefox-focus-monitor.py
-+++ b/firefox-focus-monitor.py
-@@ -1,2 +1,3 @@
-+#!/usr/bin/env python3
- """
- Utility to selectively disable keypresses to specific windows.
diff --git a/crn/packages/wm.scm b/crn/packages/wm.scm
deleted file mode 100644
index 21a13fc..0000000
--- a/crn/packages/wm.scm
+++ /dev/null
@@ -1,39 +0,0 @@
-(define-module (crn packages wm)
- #:use-module (crn packages)
- #:use-module (gnu packages wm)
- #:use-module (gnu packages image)
- #:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz)
- #:use-module (gnu packages web)
- #:use-module (guix build-system copy)
- #:use-module (guix git-download)
- #:use-module (guix gexp)
- #:use-module (guix packages)
- #:use-module ((guix licenses) #:prefix licenses:))
-
-(define-public sway-contrib
- (package
- (name "sway-contrib")
- (version "0.0.0-2024.01.20")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/OctopusET/sway-contrib")
- (commit "b7825b2")))
- (file-name (git-file-name name version))
- (sha256
- (base32 "16fa8l81zjy25nsky1i525hb7zjprqz74mbirm9b76pvksschdv5"))
- (patches (crn/search-patches "sway-contrib-python.patch"))))
- (build-system copy-build-system)
- (arguments
- '(#:install-plan
- '(("." "bin" #:include (".py"))
- ("." "bin" #:include ("grimshot"))
- ("." "man" #:include ("grimshot.1")))))
- (inputs (list sway python-wrapper))
- (propagated-inputs (list python-i3ipc jq grim))
- (home-page "https://github.com/OctopusET/sway-contrib")
- (synopsis "A collection of user-contributed scripts for sway")
- (description "Sway-Contrib is a community-driven effort to share and showcase various user-created configurations, scripts, themes, and other resources that enhance and help the Sway experience.")
- (license licenses:expat)))
diff --git a/crn/packages/xdisorg.scm b/crn/packages/xdisorg.scm
deleted file mode 100644
index 1c9cc29..0000000
--- a/crn/packages/xdisorg.scm
+++ /dev/null
@@ -1,29 +0,0 @@
-(define-module (crn packages xdisorg)
- #:use-module (crn packages)
- #:use-module (gnu packages)
- #:use-module ((gnu packages xdisorg) #:prefix gpx:)
- #:use-module (guix download)
- #:use-module (guix gexp)
- #:use-module (guix packages))
-
-;; (define-public rofi
-;; (package
-;; (inherit gpx:rofi)
-;; (version "1.7.5")
-;; (source (origin
-;; (method url-fetch)
-;; (uri (string-append "https://github.com/davatorium/rofi/"
-;; "releases/download/"
-;; version "/rofi-" version ".tar.xz"))
-;; (sha256
-;; (base32
-;; "138c4bl60p7namsb2pk8q5cdlxbdkli7zny192vk5jv5s5kczzya"))
-;; (snippet
-;; #~(begin
-;; ;; Delete pre-generated files.
-;; (for-each delete-file
-;; (list "lexer/theme-lexer.c"
-;; "lexer/theme-parser.c"
-;; "lexer/theme-parser.h"
-;; "resources/resources.c"
-;; "resources/resources.h"))))))))