aboutsummaryrefslogtreecommitdiff
path: root/crn/packages/python-xyz.scm
diff options
context:
space:
mode:
authorChristopher R. Nelson <christopher.nelson@languidnights.com>2023-03-26 12:21:08 -0400
committerChristopher R. Nelson <christopher.nelson@languidnights.com>2023-03-26 12:21:08 -0400
commit4849a5b03f8663f5f01832c2c7191c6e4dbc69bf (patch)
tree984857cab9a37556f43693c068164d360a6b9e55 /crn/packages/python-xyz.scm
initial commit
Diffstat (limited to 'crn/packages/python-xyz.scm')
-rw-r--r--crn/packages/python-xyz.scm123
1 files changed, 123 insertions, 0 deletions
diff --git a/crn/packages/python-xyz.scm b/crn/packages/python-xyz.scm
new file mode 100644
index 0000000..db5ad46
--- /dev/null
+++ b/crn/packages/python-xyz.scm
@@ -0,0 +1,123 @@
+(define-module (crn packages python-xyz))
+(use-modules (crn packages)
+ (guix build utils)
+ (guix download)
+ (guix gexp)
+ (guix packages)
+ (guix licenses)
+ (guix build-system python)
+ (guix build-system pyproject)
+ ((gnu packages) #:prefix gnu:)
+ (gnu packages check)
+ (gnu packages python-build)
+ (gnu packages python-check)
+ (gnu packages python-xyz)
+ (gnu packages python-web))
+
+(define-public python-typeguard
+ (package
+ (name "python-typeguard")
+ (version "2.13.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "typeguard" version))
+ (sha256
+ (base32
+ "1i5qzcyw2715h1g1hvj7fxykck2bkxyshpngjr3nfcx1lf6smv80"))
+ (patches (search-patches "typeguard-version.patch"))))
+ (build-system python-build-system)
+ (native-inputs (list python-mypy python-pytest python-typing-extensions))
+ (home-page "")
+ (synopsis "Run-time type checker for Python")
+ (description "Run-time type checker for Python")
+ (license expat)))
+
+(define-public python-lsprotocol
+ (package
+ (name "python-lsprotocol")
+ (version "2022.0.0a10")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "lsprotocol" version))
+ (sha256
+ (base32
+ "0l1wg3hp5agvy8dy5345bq7yll7xxxji4xp37sgrgv54nxq8gmrc"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core))
+ (inputs (list python-attrs))
+ (propagated-inputs (list python-attrs python-cattrs))
+ (home-page "")
+ (synopsis "Python implementation of the Language Server Protocol.")
+ (description "Python implementation of the Language Server Protocol.")
+ (license expat)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check))))))
+
+(define-public python-gls
+ (package
+ (name "python-gls")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri "https://files.pythonhosted.org/packages/8e/27/58ff0f76b379fc11a1d03e8d4b4e96fd0abb463d27709a7fb4193bcdbbc4/pygls-1.0.1.tar.gz")
+ (sha256
+ (base32
+ "1clcnx1s9knh6dgmf4ykrca7yq19w6kjphsvfmffp426pgfrivpk"))))
+ (build-system python-build-system)
+ (native-inputs (list python-toml python-setuptools-scm python-wheel python-typeguard))
+ (propagated-inputs (list python-lsprotocol))
+ (home-page "https://github.com/openlawlibrary/pygls")
+ (synopsis "A pythonic generic lanuage server.")
+ (description "pygls (pronounced like \"pie glass\") is a pythonic generic implementation of the Language Server Protocol for use as a foundation for writing your own Language Servers in just a few lines of code.")
+ (license asl2.0)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check))))))
+
+(define-public python-attrs
+ (package
+ (name "python-attrs")
+ (version "22.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "attrs" version))
+ (sha256
+ (base32
+ "16az31ccld8s3xj7q1iw6a402sf92lfpvcwdyq1kr6815zy7n8n9"))))
+ (build-system python-build-system)
+ (native-inputs (list
+ python-cloudpickle
+ python-hypothesis
+ python-mypy
+ python-pympler
+ python-zope-interface))
+ (home-page "https://www.attrs.org/")
+ (synopsis "Classes Without Boilerplate")
+ (description "Classes Without Boilerplate")
+ (license expat)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check))))))
+
+(define-public python-cattrs
+(package
+ (name "python-cattrs")
+ (version "22.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "cattrs" version))
+ (sha256
+ (base32
+ "0vfggbggsdni4hdis17xr8z9cnyw5klnrdp7avv3qhlr4djdbvph"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-attrs python-exceptiongroup
+ python-typing-extensions))
+ (home-page "https://github.com/python-attrs/cattrs")
+ (synopsis "Composable complex class support for attrs and dataclasses.")
+ (description "Composable complex class support for attrs and dataclasses.")
+ (license expat)))