summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher R. Nelson <christopher.nelson@languidnights.com>2024-01-20 22:23:47 -0500
committerChristopher R. Nelson <christopher.nelson@languidnights.com>2024-01-20 22:23:47 -0500
commitea411537de33d51ec3b610437e946e42e740115a (patch)
treefbb0a4a38ebee9dac86906034f38e2f80af5058a
parent5d1ab52ca380906da9056d7a4784f7d7b1826fca (diff)
security: add public key to keyringkeyring
-rw-r--r--.guix-authorizations5
-rw-r--r--.guix-channel4
-rw-r--r--crn/packages.scm49
-rw-r--r--crn/packages/cpp.scm25
-rw-r--r--crn/packages/games.scm39
-rw-r--r--crn/packages/go-xyz.scm148
-rw-r--r--crn/packages/lua-xyz.scm60
-rw-r--r--crn/packages/patches/cpplint-pytest-version.patch13
-rw-r--r--crn/packages/patches/rofi-extra-whitespace.patch13
-rw-r--r--crn/packages/patches/sway-contrib-python.patch10
-rw-r--r--crn/packages/wm.scm39
-rw-r--r--crn/packages/xdisorg.scm29
-rw-r--r--languidnights-574AD3F9.key78
-rw-r--r--news.scm21
14 files changed, 78 insertions, 455 deletions
diff --git a/.guix-authorizations b/.guix-authorizations
deleted file mode 100644
index 470078b..0000000
--- a/.guix-authorizations
+++ /dev/null
@@ -1,5 +0,0 @@
-(authorizations
- (version 0)
-
- (("2C6B 707A FE25 ADA4 3DD5 3E60 A3F4 EBEE 574A D3F9"
- (name "Christopher R. Nelson"))))
diff --git a/.guix-channel b/.guix-channel
deleted file mode 100644
index 8a49025..0000000
--- a/.guix-channel
+++ /dev/null
@@ -1,4 +0,0 @@
-(channel
- (version 0)
- (news-file "news.scm")
- (url "https://languidnights.com/guix-packages"))
diff --git a/crn/packages.scm b/crn/packages.scm
deleted file mode 100644
index 716fca2..0000000
--- a/crn/packages.scm
+++ /dev/null
@@ -1,49 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020 Andrew Whatson <whatson@gmail.com>
-;;;
-;;; This file is NOT part of GNU Guix.
-;;;
-;;; This program is free software: you can redistribute it and/or modify
-;;; it under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation, either version 3 of the License, or
-;;; (at your option) any later version.
-;;;
-;;; This program is distributed in the hope that it will be useful,
-;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (crn packages)
- #:use-module ((gnu packages) #:prefix gnu:)
- #:use-module (guix diagnostics)
- #:use-module (guix i18n)
- #:use-module ((srfi srfi-1) #:prefix srfi:)
- #:export (crn/search-patch
- crn/search-patches
- %patch-path))
-
-(define %channel-root
- (srfi:find (lambda (path)
- (file-exists? (string-append path "/crn/packages.scm")))
- %load-path))
-
-(define %patch-path
- (make-parameter
- (cons
- (string-append %channel-root "/crn/packages/patches")
- (gnu:%patch-path))))
-
-(define (crn/search-patch file-name)
- "Search the patch FILE-NAME. Raise an error if not found."
- ;;(search-path (%patch-path) file-name))
- (or (search-path (%patch-path) file-name)
- (raise (formatted-message (G_ "~a: patch not found")
- file-name))))
-
-(define-syntax-rule (crn/search-patches file-name ...)
- "Return the list of absolute file names corresponding to each
-FILE-NAME found in %PATCH-PATH."
- (list (search-path (%patch-path) file-name) ...))
diff --git a/crn/packages/cpp.scm b/crn/packages/cpp.scm
deleted file mode 100644
index 4120342..0000000
--- a/crn/packages/cpp.scm
+++ /dev/null
@@ -1,25 +0,0 @@
-(define-module (crn packages cpp)
- :use-module (crn packages)
- :use-module (gnu packages)
- :use-module (gnu packages cpp)
- :use-module (guix packages)
- :use-module (guix git-download))
-
-(define-public cpplint-up
- (package (inherit cpplint)
- (name "cpplint-up")
- (version "1.5.5")
- (source
- (origin
- (method git-fetch)
- ;; Fetch from github instead of pypi, since the test cases are not in
- ;; the pypi archive.
- (uri (git-reference
- (url "https://github.com/cpplint/cpplint")
- (commit version)))
- (sha256
- (base32 "13l86aq0h1jga949k79k9x3hw2xqchjc162sclg2f99vz98zcz15"))
- (file-name (git-file-name name version))
- (patches (crn/search-patches "cpplint-pytest-version.patch"))))))
-
-cpplint-up
diff --git a/crn/packages/games.scm b/crn/packages/games.scm
deleted file mode 100644
index c41106a..0000000
--- a/crn/packages/games.scm
+++ /dev/null
@@ -1,39 +0,0 @@
-(define-module (crn packages games)
- #:use-module (gnu packages)
- #:use-module (gnu packages sdl)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix build-system gnu)
- #:use-module (guix download)
- #:use-module (guix gexp)
- #:use-module (guix packages)
- #:use-module (guix utils)
- #:use-module (srfi srfi-26))
-
-(define-public black-box
- (package
- (name "black-box")
- (version "1.4.8")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.linux-games.com/" name "/" name "-" version ".tar.gz"))
- (sha256
- (base32 "1gbkkf05qy6zz0s2v1yyjrhrnw0nxl1ldzm4fdlwi1z4jqda7xlw"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-SDL
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "CPATH"
- (string-append
- (assoc-ref inputs "sdl-union") "/include/SDL:"
- (or (getenv "CPATH") ""))))))))
- (inputs (list (sdl-union (list sdl sdl-mixer sdl-image))))
- (synopsis "Guess where the crystals are!")
- (description "There's a black box.
-You can shoot in and watch, where the shot leaves the box. In the box,
-crystals are reflecting the shots. You have to guess where the crystals
-are hidden, by watching your shots.")
- (home-page "https://www.linux-games.com/black-box/")
- (license license:gpl2+)))
diff --git a/crn/packages/go-xyz.scm b/crn/packages/go-xyz.scm
deleted file mode 100644
index f40aee8..0000000
--- a/crn/packages/go-xyz.scm
+++ /dev/null
@@ -1,148 +0,0 @@
-(define-module (crn packages go-xyz)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix gexp)
- #:use-module (guix git-download)
- #:use-module (guix utils)
- #:use-module (gnu packages)
- #:use-module (gnu packages golang)
- #:use-module (gnu packages golang-check))
-
-(define-public go-1.21
- (package
- (inherit go-1.20)
- (name "go")
- (version "1.21.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/golang/go")
- (commit (string-append "go" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xp1mqjbbs53bjg00d4a37af5p1by28xnflj2xi5kchcpmlqn5nz"))))
- (arguments
- (substitute-keyword-arguments (package-arguments go-1.20)
- ;; Source patching phases are broken up into discrete steps to
- ;; allow future versions to discard individual phases without
- ;; having to discard all source patching.
- ((#:phases phases)
- #~(modify-phases #$phases
- (delete 'skip-TestGoPathShlibGccgo-tests)
- (delete 'patch-source)
- (add-after 'unpack 'patch-os-tests
- (lambda _
- (substitute* "src/os/os_test.go"
- (("/usr/bin") (getcwd))
- (("/bin/sh") (which "sh")))))
-
- (add-after 'unpack 'apply-patches
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Having the patch in the 'patches' field of <origin>
- ;; breaks the 'TestServeContent' test due to the fact
- ;; that timestamps are reset. Thus, apply it from here.
- (invoke "patch" "-p1" "--force" "-i"
- (assoc-ref inputs "go-fix-script-tests.patch"))))
-
- (add-after 'unpack 'patch-src/net
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((net-base (assoc-ref inputs "net-base")))
- (substitute* "src/net/lookup_unix.go"
- (("/etc/protocols")
- (string-append net-base "/etc/protocols")))
- (substitute* "src/net/port_unix.go"
- (("/etc/services")
- (string-append net-base "/etc/services"))))))
-
- (add-after 'unpack 'patch-zoneinfo
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Add the path to this specific version of tzdata's
- ;; zoneinfo file to the top of the list to search. We
- ;; don't want to replace any sources because it will
- ;; affect how binaries compiled with this Go toolchain
- ;; behave on non-guix platforms.
- (substitute* "src/time/zoneinfo_unix.go"
- (("var platformZoneSources.+" all)
- (format #f "~a~%\"~a/share/zoneinfo\",~%"
- all
- (assoc-ref inputs "tzdata"))))))
-
- (add-after 'unpack 'patch-cmd/go/testdata/script
- (lambda _
- (substitute* "src/cmd/go/testdata/script/cgo_path_space.txt"
- (("/bin/sh") (which "sh")))))
-
- (add-after 'enable-external-linking 'enable-external-linking-1.21
- (lambda _
- ;; Invoke GCC to link any archives created with GCC
- ;; (that is, any packages built using 'cgo'), because Go
- ;; doesn't know how to handle the runpaths but GCC does.
- ;; Use substitute* rather than. a patch since these
- ;; files are liable to change often
- ;;
- ;; XXX: Replace with GO_EXTLINK_ENABLED=1 or similar
- ;; when <https://github.com/golang/go/issues/31544>
- ;; and/or <https://github.com/golang/go/issues/43525>
- ;; are resolved.
- (substitute* "src/cmd/link/internal/ld/config.go"
- (("\\(iscgo && \\(.+\\)") "iscgo"))
- (substitute* "src/internal/testenv/testenv.go"
- (("!CanInternalLink.+") "true {\n"))
- (substitute* "src/syscall/exec_linux_test.go"
- (("testenv.MustHaveExecPath\\(t, \"whoami\"\\)")
- "t.Skipf(\"no passwd file present\")"))))
-
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Notably, we do not install archives (180M), which Go
- ;; will happily recompile quickly (and cache) if needed,
- ;; almost surely faster than they could be substituted.
- ;;
- ;; The main motivation for pre-compiled archives is to
- ;; use libc-linked `net' or `os' packages without a C
- ;; compiler, but on Guix a C compiler is necessary to
- ;; properly link the final binaries anyway. Many build
- ;; flags also invalidate these pre-compiled archives, so
- ;; in practice Go often recompiles them anyway.
- ;;
- ;; Upstream is also planning to no longer install these
- ;; archives: <https://github.com/golang/go/issues/47257>
- ;;
- ;; When necessary, a custom pre-compiled library package
- ;; can be created with `#:import-path "std"' and used
- ;; with `-pkgdir'.
- ;;
- ;; When moving files into place, any files that come
- ;; from GOROOT should remain in GOROOT to continue
- ;; functioning. If they need to be referenced from some
- ;; other directory, they need to be symlinked from
- ;; GOROOT. For more information, please see
- ;; https://github.com/golang/go/issues/61921
- (let* ((out (assoc-ref outputs "out"))
- (tests (assoc-ref outputs "tests")))
- (for-each
- (lambda (file)
- (copy-recursively file (string-append out "/lib/go/" file)))
- '("bin" "go.env" "lib" "VERSION" "pkg/include" "pkg/tool"))
-
- (symlink "lib/go/bin" (string-append out "/bin"))
-
- (for-each
- (match-lambda
- ((file dest output)
- ;; Copy to output/dest and symlink from
- ;; output/lib/go/file.
- (let ((file* (string-append output "/lib/go/" file))
- (dest* (string-append output "/" dest)))
- (copy-recursively file dest*)
- (mkdir-p (dirname file*))
- (symlink (string-append "../../" dest) file*))))
- `(("src" "share/go/src" ,out)
- ("misc" "share/go/misc" ,out)
- ("doc" "share/doc/go/doc" ,out)
- ("api" "share/go/api" ,tests)
- ("test" "share/go/test" ,tests))))))))))))
-
-(define-public go-std-1.21 (make-go-std go-1.21))
diff --git a/crn/packages/lua-xyz.scm b/crn/packages/lua-xyz.scm
deleted file mode 100644
index 286ecd3..0000000
--- a/crn/packages/lua-xyz.scm
+++ /dev/null
@@ -1,60 +0,0 @@
-(define-module (crn packages lua-xyz))
-(use-modules (guix git)
- (guix git-download)
- (guix gexp)
- (guix download)
- (guix packages)
- (guix licenses)
- (guix build-system cmake)
- (guix utils)
- (gnu packages)
- (gnu packages bash)
- (gnu packages glib)
- (gnu packages linux)
- (gnu packages lua)
- (gnu packages pkg-config)
- (gnu packages python-xyz)
- (gnu packages valgrind)
- (gnu packages xorg)
- (gnu packages web))
-
-(define-public luastatus
- (package
- (name "luastatus")
- (version "0.6.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/shdown/luastatus")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1xyh220par0f8l8ylh6jx0qzskafwy1hi0v1dw22qs0g6nkbj4y2"))))
- (build-system cmake-build-system)
- (native-inputs (list lua
- pkg-config
- python-docutils
- valgrind))
- (inputs (list alsa-lib
- bash
- xcb-util
- yajl
- glib
- libnl
- eudev
- libx11
- libxcb
- xcb-util-wm))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "../source/tests/misc.sh" ".")
- (invoke "../source/tests/torture.sh" ".")))))))
- (home-page "https://github.com/shdown/luastatus")
- (synopsis "Universal status bar content generator")
- (description "Luastatus is a universal status bar content generator.
-It allows you to configure the way the data from event sources is
-processed and shown, with Lua.")
- (license gpl3)))
diff --git a/crn/packages/patches/cpplint-pytest-version.patch b/crn/packages/patches/cpplint-pytest-version.patch
deleted file mode 100644
index a388d4a..0000000
--- a/crn/packages/patches/cpplint-pytest-version.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 0297e74..357adcb 100755
---- a/setup.py
-+++ b/setup.py
-@@ -75,7 +75,7 @@ setup(name='cpplint',
- long_description=open('README.rst').read(),
- license='BSD-3-Clause',
- setup_requires=[
-- "pytest-runner==5.2"
-+ "pytest-runner"
- ],
- tests_require=test_required,
- # extras_require allow pip install .[dev]
diff --git a/crn/packages/patches/rofi-extra-whitespace.patch b/crn/packages/patches/rofi-extra-whitespace.patch
deleted file mode 100644
index 1d065f7..0000000
--- a/crn/packages/patches/rofi-extra-whitespace.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/source/modes/dmenu.c b/source/modes/dmenu.c
-index 27b6097d..85dda8e5 100644
---- a/source/modes/dmenu.c
-+++ b/source/modes/dmenu.c
-@@ -391,7 +391,7 @@ static gchar *dmenu_format_output_string(const DmenuModePrivateData *pd,
- unsigned int index =
- (unsigned int)g_ascii_strtoull(pd->columns[i], NULL, 10);
- if (index <= ns && index > 0) {
-- if (i == 0) {
-+ if (index == 1) {
- g_string_append(str_retv, splitted[index - 1]);
- } else {
- g_string_append_c(str_retv, '\t');
diff --git a/crn/packages/patches/sway-contrib-python.patch b/crn/packages/patches/sway-contrib-python.patch
deleted file mode 100644
index ff4f344..0000000
--- a/crn/packages/patches/sway-contrib-python.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/firefox-focus-monitor.py b/firefox-focus-monitor.py
-old mode 100644
-new mode 100755
-index d2a2d42..659b893
---- a/firefox-focus-monitor.py
-+++ b/firefox-focus-monitor.py
-@@ -1,2 +1,3 @@
-+#!/usr/bin/env python3
- """
- Utility to selectively disable keypresses to specific windows.
diff --git a/crn/packages/wm.scm b/crn/packages/wm.scm
deleted file mode 100644
index 21a13fc..0000000
--- a/crn/packages/wm.scm
+++ /dev/null
@@ -1,39 +0,0 @@
-(define-module (crn packages wm)
- #:use-module (crn packages)
- #:use-module (gnu packages wm)
- #:use-module (gnu packages image)
- #:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz)
- #:use-module (gnu packages web)
- #:use-module (guix build-system copy)
- #:use-module (guix git-download)
- #:use-module (guix gexp)
- #:use-module (guix packages)
- #:use-module ((guix licenses) #:prefix licenses:))
-
-(define-public sway-contrib
- (package
- (name "sway-contrib")
- (version "0.0.0-2024.01.20")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/OctopusET/sway-contrib")
- (commit "b7825b2")))
- (file-name (git-file-name name version))
- (sha256
- (base32 "16fa8l81zjy25nsky1i525hb7zjprqz74mbirm9b76pvksschdv5"))
- (patches (crn/search-patches "sway-contrib-python.patch"))))
- (build-system copy-build-system)
- (arguments
- '(#:install-plan
- '(("." "bin" #:include (".py"))
- ("." "bin" #:include ("grimshot"))
- ("." "man" #:include ("grimshot.1")))))
- (inputs (list sway python-wrapper))
- (propagated-inputs (list python-i3ipc jq grim))
- (home-page "https://github.com/OctopusET/sway-contrib")
- (synopsis "A collection of user-contributed scripts for sway")
- (description "Sway-Contrib is a community-driven effort to share and showcase various user-created configurations, scripts, themes, and other resources that enhance and help the Sway experience.")
- (license licenses:expat)))
diff --git a/crn/packages/xdisorg.scm b/crn/packages/xdisorg.scm
deleted file mode 100644
index 1c9cc29..0000000
--- a/crn/packages/xdisorg.scm
+++ /dev/null
@@ -1,29 +0,0 @@
-(define-module (crn packages xdisorg)
- #:use-module (crn packages)
- #:use-module (gnu packages)
- #:use-module ((gnu packages xdisorg) #:prefix gpx:)
- #:use-module (guix download)
- #:use-module (guix gexp)
- #:use-module (guix packages))
-
-;; (define-public rofi
-;; (package
-;; (inherit gpx:rofi)
-;; (version "1.7.5")
-;; (source (origin
-;; (method url-fetch)
-;; (uri (string-append "https://github.com/davatorium/rofi/"
-;; "releases/download/"
-;; version "/rofi-" version ".tar.xz"))
-;; (sha256
-;; (base32
-;; "138c4bl60p7namsb2pk8q5cdlxbdkli7zny192vk5jv5s5kczzya"))
-;; (snippet
-;; #~(begin
-;; ;; Delete pre-generated files.
-;; (for-each delete-file
-;; (list "lexer/theme-lexer.c"
-;; "lexer/theme-parser.c"
-;; "lexer/theme-parser.h"
-;; "resources/resources.c"
-;; "resources/resources.h"))))))))
diff --git a/languidnights-574AD3F9.key b/languidnights-574AD3F9.key
new file mode 100644
index 0000000..b62d331
--- /dev/null
+++ b/languidnights-574AD3F9.key
@@ -0,0 +1,78 @@
+-----BEGIN PGP PUBLIC KEY BLOCK-----
+
+mQINBGC1nAkBEACwPNo8UgTyz+7bQZtMTgVX5TcLOQL/ZqNALPuZBCIuBBzuciud
+YV+YuCul4sI/1sWNfLO0JwMttPaL4Jc5DVFghmghQ9+p4lr78SjM5AOPTtu1wkAF
+c2jK7ems1RGnBiCmgqIWOcbb5rCrk6CSW/+OnG2lQ4KzYoN7+t8qPrq0725SV5WQ
+SiIk2Eo+3wUXCLnPlZd6AJDSwnQNExaw/v+heHwmUnImiidJaTsWWOMe2nLohEq6
+QlM7ErJITO7lZzeegv3k5+m/v/Y+TXyVMdm42fXVTN9KYvfpGQuokJuNug3t1URV
+nYajUUUTiMeaLyEyh0OzhLf1/7DwnKgg7oEr3wJKYfHmV7ImXA/BW5orb9MIEUpb
+wZJvyBrkIYmHyi8K467vzK2R0hu8YJAKZ8VrC6NhSNcFDFbV8NlDsyBVUfgzEtWX
+6x8sZ75p0zgJbw54X5zxiUihlDCQoBuLeCPcTJIzmIl0yVMZtU3jkYORiFplCkJS
+aIymGlFrTfHBFFEY5eDEcF2PbWwBFYbwqWeXnlDUDfoMJbKNNIu07j5eaRFz1Bw9
+Ve+Wcr1pWJ3wW5mfKIr60NjcUGAJ6mIh1yeXgnbNGBpZAJ8sBpKBfgEm9xQONwMh
+s4w8xGhW+xuwDoxOQd8thgqUCm2NXhAX3DN1TWr6Ffbp9aSPmxRR+qGMxwARAQAB
+tDxDaHJpc3RvcGhlciBSLiBOZWxzb24gPGNocmlzdG9waGVyLm5lbHNvbkBsYW5n
+dWlkbmlnaHRzLmNvbT6JAk4EEwEKADgWIQQsa3B6/iWtpD3VPmCj9OvuV0rT+QUC
+YLWcCQIbAwULCQgHAgYVCgkICwIEFgIDAQIeAQIXgAAKCRCj9OvuV0rT+RZvD/4q
+PKkRtTh0SWZiBl4GEfJESIJJr3EHCnksg66YlrTtqQ4Fb0Yi0Qt3IONmYqSOGeqR
+xaFnc7n02QEqklvSXuvi3JCjibE2yDLW0wr+l82Fjw/E7b2ZbFTYGzv4Y38Z2kft
+DF92jImQOrCjXaS0XDXqy4tk7Kxdw20Xci1OUkwBmA3lNi2xv2TSflUAtL30cHkP
+kvFLPhbNU+iixG5XQFXzJvCp97hoUQbI89Oh1w1XMHB4SWI9GmVpKXvtAym+lIfs
+LPvh4pbq3Q/fPvfrt4+4tSTCtXZ8ur6oqOKc0IXDvfM3KEKu2SgEbw9CyauuOr4z
+H7gc2oxwTePk9bWJBeeIUhmi/bdhyAFJ7MHcj3bM+1y8Kljv+Y0TWgxUZpZ0CVC7
+YPU+KAXbDA2CzP2b/XRaaFtM7AauzKvDNGRpiYB0pO3T0EWXlB9KrNpTeYy6fDYV
+w7HBq/GWGXE9v6hQn6mn1Aif1T1J+y50OGi4rIg12fifGqgVZNDsOQUzdQKGEDwC
+lODekfDvJ6fZuMBsjHmSjQFwVU4CqXBLZQ0Z+wZngRMjnh/KEm8xGDHLDOJBYrJQ
+5ToWSdgm8xqM7C8RApMERrTaBfjtkSdvgemUpszXb1EY6dzPaOGh5jUix+KbSrzH
+0NxNaRcWWnhemvBTtsXESXO+91AeDo5ampjRgGV/ULkCDQRgtZwJARAA7j0RCV36
+4UMMs81m1KrkSyiC2Ejq2E8anZoiekcl+a95D4MjrAt9HaVio3Zp5X5YuZDeStQT
+y2HTh5h63TBDHpYQvTxexYeg6fyPeav8zYzW+zcTa0k6rLjn8ojDJ9O3Y9X3vj2w
+1nSbgLuHLa5em4LT6xOwNeFz29Y3vKjZPsM5ViYur76jfyRlYfIl4D0hl9s3INUV
++xNbx0eTTq5YkxQ+XXFCCmvpizkpwaQMIyGtEKaUeyZCgRHvSfM49uGig0sPioV8
+mc9YvaF+1OAjfvqPzKjRZjhLDd5b511TCvV45pFAUXS8FJ527hIgox0cV817YPfo
+K7/RiWce6H0KmJS5vg12bYqRq2RMA1P8o2i1FdWLRccRVK24wZGHCpd0CIBTGlhv
+TA1G33F5eI2KO6wBhBM0Bx7WWhEwDeMvGvuCwx+GgW1kEaQCs0hvUccDGLW7jXUd
+0dmxU7dbrTA9cTvEKJLx8PRKqOB0ApLcYOziFcMjfaz16UGOSIYy98s5idH4iVad
+BnSnzbfZpVARtYQdwPwPQ6uS0rujSSEkiTTUdx43q+jpEuJ+Dun+d6w4WtlwrCCe
+1sM9f0CvqioERWoGt968R8yJjEAMcAc9Mz9e9vawCzVZHCVlYhbFYb7RHXL5D+5O
+WBFkCPU2haelgGEKPRdwFE70CJ7C5zzAxtcAEQEAAYkCNgQYAQoAIBYhBCxrcHr+
+Ja2kPdU+YKP06+5XStP5BQJgtZwJAhsMAAoJEKP06+5XStP5n40P/1TPf1HxUtfd
+YpA4XAEGl/Y++ssFVWLbAfXwJSJ3O+nlMDWmKYz+94sb/fOWGeg2Q0crXRQzxXBX
+mr2sg7JEJaoCCNCw1ddg4Y/bVw133bZW2B1KZlD/DszBUnvLlWZNVNPcRUe6OTHw
+g6yNACmDacwnG/gWbd1r9gg2pKABY53DqfGrqHbToOngJh4ROZ7XWbg3yDmpEm4/
+H4uncYIK85GCAlMpaqDoPTUS9Bz0hAoWsaR/K5X1UUKTQmKqmpxAcpXkirs8FO0X
+jcfNByqCZsh7dlBzTnTqTgjw7ie5MWvnBl90xXqSuEoQ8T0YBnXtvxQUzhWWui1h
+qF3+BOJmsuq5mmm14I2o5iUngc5hUwJW7oUzt5Of0RjXUn9eXXD2+xDhLgX1HU7I
+1jXagoqf4bzU4pxTFKW7FmsQWlB4Vg/o+NaZ9b/2GbY94D0fiKEQuk7vUctzKNI+
+ydr07k1hDuKqi/ufn6CblOWYAFqfV8x0m/vA+f0dR9Yu5wqryvy/yjWvK7RffxFh
+jC4pkU6ftowtGID8/ywMHShrzDTXGRmyJmEv9D9ZdgSWZMg92x9+8POxlLH0xK10
+pQIj2j8X3BDqVQ45HvgK+SWfs6wrjxmzskzmfMZeSj+g7nGX+sF6Y4uTI6rQs3rF
+vfF40esWTFKNAvtuBNaSO6UqIV4NH0numQENBGC6NnYBCADWJcrWSh1vDjitk2vK
+Cg63T0zGd+00zpRswKLWwS52063DgdcXzD5te1rJbmTf83NWHEQXEKwMZw+z8Teu
+gmIEktlJNRXri3uakhKJyf4Io+IbT6/UKbVoje5sfVN3aE9IhZb8Ejah9vR1mZWj
+O1lZmnGHU6bC9y67Xqkj5cPUxBDV+ayh3MN6yf37Gj+RgHnk27OyrZLsMccRAnYL
+U6GL4J7FIus70tRXyrO14LIbWdRUPnDyeryqo6qrRI1XAIuQ8UXBrvAlHca6gefs
+68HJpryQHiTBvnoQrJLGTaUuZflF8Qvdv2J6nLULR3UTvo0lmh88Znyw5ajSNVrm
+btsRABEBAAG0PENocmlzdG9waGVyIFIuIE5lbHNvbiA8Y2hyaXN0b3BoZXIucmlj
+aGFyZC5uZWxzb25AZ21haWwuY29tPokBTgQTAQoAOBYhBCACNiAlOoaH3QEBYX2+
+KDZKdGygBQJgujZ2AhsDBQsJCAcCBhUKCQgLAgQWAgMBAh4BAheAAAoJEH2+KDZK
+dGyg5eMIANR+u2q9Y2FJgLuEuUaK97F4VNEOh1TdA1WW/+XqBk7VvgZ9rPzx0DrO
+rsUUyCbk2s0mdga7tvdgHe2/wh33CgDVxRLX4HyRFsvCGwrEvnupFNUTCacNOMyf
+HbqFbIBC3XBlX8T6v9z+1LmS5d6AOQqQMsrb3vt7uSXYzmv7caRdFnt/41VAEsqI
+pOAwuOQ5rOUXjpyJGQqhGmXVHX8xvon+8UL0GGABBcx4hrJLEprFmvq1P0e1zYgf
+Bxero5lk6FW5MrV96VzEc73yOykFxmysW0NiV9oysh+BcuqIlyLVExSqHrev8Uw/
+SiIuIvI7cUEhqkTZoec2tTnomYNGBEq5AQ0EYLo2dgEIAK4QiJTP3HtUwLFpunZs
+FxxB/Pm+B+HTi6SW6XhUeqd0RTbbUqMPIFv3H2MRI1l5XvOCIzYvSw9e0IIQyeKH
+8v/zgrOZPKqfvBOwguZQpye9fOLN7QwDc7DRLPq1xEw/8TehBges4+59oX4UzHb+
+92Kih8Yqxa/VKbHx2yX5nQjDW0LgOCrn9UIU4WkYP9DuRW2KYo6JoHOkJAnsiTRd
+akssI6on2m2ThHJ27sEoty/fyfwSglD623T99FnNBwV9YMkYMMWRFX/rrXxbyKoW
+7Zfqjzt/MTJsvBHn1vTAnWYxe6WgMOoMVUNrCfwyx8LsurhtBy+bI9j6TatDaPnb
+LY8AEQEAAYkBNgQYAQoAIBYhBCACNiAlOoaH3QEBYX2+KDZKdGygBQJgujZ2AhsM
+AAoJEH2+KDZKdGygOqkH/3kGr6Cpl2TRxguaATUBzEVTNYShiBF/JzsYJVIohw9R
+nTGLxyJ9KVo6EfQz1K6Rg0a+i9ouA7TXQ3D4BDIUXswCIXJxbFXnFz2pz4K1WCez
+9TU34qqPwjpEks/VrB08tIOF7k6X7klBbqZO40zAKxNIS0LG5KuFKnwJvtbJiloc
+ZhJL7Gqg9DjAaEDmLIdtzgdH218Fh6eWDcqg80SNAUqjOQGetb/srwjz+GY0g9wR
+6c4QpPmwTzxmjFAb+Yh9xSgh7QGQzYIoELq2yOurkM67qwPPe0jYai0TS6tPcIHY
+7TeB0S94dGBOtrzrQATEj9UY9KA3zU3eQ2ptmv3HTk4=
+=STuU
+-----END PGP PUBLIC KEY BLOCK-----
diff --git a/news.scm b/news.scm
deleted file mode 100644
index 494ddde..0000000
--- a/news.scm
+++ /dev/null
@@ -1,21 +0,0 @@
-(channel-news
- (version 0)
-
- (entry (commit "fd51369453074f1d54081e2f0af270743c4db24f")
- (title
- (en "languidnights Authenticated Updates"))
- (body
- (en "languidnights' channel can now take advantage of authenticated updates in @command{guix pull}, which lets you know any malware you find here, I personally signed off on.
-
-To ensure you only get the highest quality unintended consequences, you should update your @file{~/.config/guix/channels.scm} to include the following
-
-@lisp
-(channel
- (name \"languidnights\")
- (branch \"main\")
- (url \"git://languidnights.com/guix-packages\")
- (introduction
- (make-channel-introduction \"fd51369453074f1d54081e2f0af270743c4db24f\"
- (openpgp-fingerprint
- \"2C6B 707A FE25 ADA4 3DD5 3E60 A3F4 EBEE 574A D3F9\"))))
-@end lisp"))))