summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher R. Nelson <christopher.nelson@languidnights.com>2024-01-17 21:13:48 -0500
committerChristopher R. Nelson <christopher.nelson@languidnights.com>2024-01-21 09:59:05 -0500
commitb2c4d5b69d64bde980b7b318ef992524921c603b (patch)
treeb3315f039cd1a6c67da571e9ae4ff34326e55018 /configure.ac
parent6294af2472ff9798f46f01acf49b39f50f0375ec (diff)
Commit (current) autotools files
Normally, you don't commit generated files to vcs. In this case, we are doing so because many/most users won't have guile-hall installed, and we'd rather not force users to install a development dependency when they can install just autotools. .gitignore: rh-server && rh-client are built by make
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..d4275ff
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(guile-reading-heap, 0.1)
+AC_SUBST(HVERSION, "\"0.1\"")
+AC_SUBST(AUTHOR, "\"Christopher R. Nelson\"")
+AC_SUBST(COPYRIGHT, "'(2024)")
+AC_SUBST(LICENSE, agpl3+)
+AC_CONFIG_SRCDIR(reading-heap.scm)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([1.12 gnu silent-rules subdir-objects color-tests parallel-tests -Woverride -Wno-portability])
+AM_SILENT_RULES([yes])
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+AC_CONFIG_FILES([scripts/rh-server],[chmod +x scripts/rh-server])
+AC_CONFIG_FILES([scripts/rh-client],[chmod +x scripts/rh-client])
+dnl Search for 'guile' and 'guild'. This macro defines
+dnl 'GUILE_EFFECTIVE_VERSION'.
+GUILE_PKG([3.0 2.2 2.0])
+GUILE_PROGS
+GUILE_SITE_DIR
+if test "x$GUILD" = "x"; then
+ AC_MSG_ERROR(['guild' binary not found; please check your guile-2.x installation.])
+fi
+
+dnl Hall auto-generated guile-module dependencies
+GUILE_MODULE_REQUIRED([hall common])
+
+dnl Installation directories for .scm and .go files.
+guilemoduledir="${datarootdir}/guile/site/$GUILE_EFFECTIVE_VERSION"
+guileobjectdir="${libdir}/guile/$GUILE_EFFECTIVE_VERSION/site-ccache"
+AC_SUBST([guilemoduledir])
+AC_SUBST([guileobjectdir])
+
+AC_OUTPUT